Accueil Forum Accueil Forum >

iziSpot : Création de site internet

> Discussions générales
  Nouveaux messages Nouveaux messages Fil RSS  - Fatal error à la mise en ligne
  FAQ FAQ  Rechercher dans le Forum   Inscription Inscription  Connexion Connexion

Fatal error à la mise en ligne

 Répondre Répondre
Auteur
Message
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Sujet: Fatal error à la mise en ligne
    Envoyé : 08 Décembre 2017 à 11:18
Bonjour,
depuis ce matin, la mise en ligne de mon site IziSpot (version 4.70) se termine toujours avec ce message :  Fatal error: Call to undefined function pg_escape_string(). Cry
Et pourtant la mise en ligne parait OK.
Avez-vous une idée de ce qui se passe ? Serait-ce du à mon site ou au serveur Free qui l'accueil ?
Merci d'avance pour votre aide
Alain
Petite précision : la mise en ligne à l'air de fonctionner !


Edité par Matt Izi - 16 Janvier 2018 à 09:41
Haut de la page
Matt Izi allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 02 Avril 2007
Statut: Inactif
Points: 5758
Options des messages Options des messages   Merci (0) Merci(0)   Citer Matt Izi Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 11 Décembre 2017 à 09:25
Bonjour,
Allez dans les options avancées de mise en ligne puis cliquez sur 'valeurs par défaut'.
Retournez sur l'onglet 'Identification', saisissez vos paramètres de mise en ligne et refaites une mise en ligne en mode 'complet'.
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 11 Décembre 2017 à 12:24
Salut Matt,
je viens de suivre tes indications mais même résultat : Fata error ...
J'ai refait une mise en production partielle et idem Cry

Fatal error: Call to undefined function pg_escape_string() in /disk-data/ftp/00/nn/nn/root/izispot/class/funct.class.php on line 52

Merci !

Alain

Petite précision : la mise en ligne à l'air de fonctionner !



Edité par alainjjb - 11 Décembre 2017 à 12:35
Haut de la page
Matt Izi allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 02 Avril 2007
Statut: Inactif
Points: 5758
Options des messages Options des messages   Merci (0) Merci(0)   Citer Matt Izi Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 12 Décembre 2017 à 09:30
Bonjour,
Vu l'erreur, je pense qu'il faudrait désinstaller iziSpot et refaire une installation complète.
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 16 Décembre 2017 à 10:16
Bonjour,
Je viens de désinstaller et réinstaller IziSpot. Ensuite j'ai refait une mise à jour partielle puis complète. j'obtiens dans les 2 cas ce fameux message à la fin de la mise en production : Fatal error ... ligne 52. Cry
Mais la mise en production se passe apparemment bien. Ce qui est le principal. Smile
Mais avoir un message d'erreur n'est jamais très rassurant.
Merci quand même
Alain

PS. Je viens d'envoyer un message à l'hébergeur Free pour voir si ça ne peut pas venir de lui. Je vous tiens au courant


Edité par alainjjb - 16 Décembre 2017 à 13:12
Haut de la page
BOREAL allez vers le bas
Newbie
Newbie


Depuis le: 04 Septembre 2011
Pays: Belgium
Statut: Inactif
Points: 7
Options des messages Options des messages   Merci (0) Merci(0)   Citer BOREAL Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 26 Décembre 2017 à 14:46
BONJOUR

j'ai voulu mettre en ligne mon site et j'ai le même message 

fatal error:call to undefined function pg_escape_string() in/disk-data/ftp/00/76/25/root/izispot/class/funct.class.php pn line 52

mais l'animation flash reste bloquée

merci
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 04 Janvier 2018 à 10:28
Bonjour,
j'ai contacté FREE via les groupes de discussion. Voilà un résumé de notre discussion :
Free : Quelle version de PHP est utilisée ?
Moi : Après recherche la version Php utilisée est : PHP Version 4.4.3-dev

Free : Donc mettre la directive qui va bien dans le fichier .htaccess de la
racine pour passer en php 5.1 ou php 5.6 (selon les serveurs).
Mais voilà. Je ne trouve pas de fichier .htaccess dans la racine du site.
Que dois-je faire ?
Merci
Alain
Haut de la page
Matt Izi allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 02 Avril 2007
Statut: Inactif
Points: 5758
Options des messages Options des messages   Merci (0) Merci(0)   Citer Matt Izi Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 04 Janvier 2018 à 12:06
Bonjour,
Il n'y a pas de fichier .htaccess par défaut créé par iziSpot.
Il faut le créer et l'uploader sur votre hébergement chez free.
Cependant, je ne suis pas sur que cela apporte quelque chose.
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 05 Janvier 2018 à 10:14
Bonjour,
effectivement ! J'ai testé la création de ce fameux fichier .htaccess avec les valeurs php 1 et php56 1
que j'ai placé à la racine de mon site sur le serveur de Free. La mise en production s'est terminée par le même message "Fatal error ... ligne 52". Cry
Avez-vous une autre idée ???
Merci
Alain

Haut de la page
Matt Izi allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 02 Avril 2007
Statut: Inactif
Points: 5758
Options des messages Options des messages   Merci (0) Merci(0)   Citer Matt Izi Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 05 Janvier 2018 à 10:27
Bonjour,
Cette erreur est assez étrange. Avez-vous essayé de vider votre espace d'hébergement et de refaire une mise en ligne en mode complet ?
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 05 Janvier 2018 à 15:16
Oui, oui ! j'ai déjà testé la mise en ligne complète. Mais rien ni fait.
Je suis tjs en discussion avec le groupe de discussion Free.
Je vous tiens au courant.
Merci
Alain
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 05 Janvier 2018 à 15:58
Est-ce que ce msg complet pourrait vous permettre d'identifier son origine :
"Call to undefined function pg_escape_string() in /disk-data/ftp/00/76/25/root/izispot/class/funct.class.php on line 52" ?
et pourquoi pas identifier la page incriminée.
Sinon j'ai exporté le site en HTML. Est-ce que je peux trouver (ou plutôt chercher quelque chose dedans ?
Et vous, si je vous transmets l'URL du site, vous pourriez chercher de votre côté ?

Pour info j'ai mis sur le serveur un fichier .htaccess pour accèder à PHP Version 5.6.8
Merci


Edité par alainjjb - 05 Janvier 2018 à 16:46
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 12 Janvier 2018 à 16:21
Bonjour,
    je crois que tout le monde est "Sec" Cry devant ce msg. Le new group de Free spécialisé dans les pages perso (hébergement de chez Free) reste sans réponse.
    N'y a-t-il pas moyen, pour vous de consulter le fichier "root/izispot/class/funct.class.php root/izispot/class/funct.class.php"  ? et de consulter cette fameuse ligne 52 ?

Un contributeur du groupe m'a répondu :
"Cette fonction : pg_escape_string() est liée à PHP et plus particulièrement aux fonctions de PostGreSQL, voir : http://php.net/manual/fr/function.pg-escape-string.php

Au vu de l'erreur, il semblerait que la page PHP concernée ne puisse accéder à la fonction, car inexistante sur l'hébergement que tu utilises".

Qu'en pensez-vous ?
Merci
Alain


Edité par alainjjb - 12 Janvier 2018 à 17:26
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 15 Janvier 2018 à 16:08
Bonjour à tous,
Eh bien, vous n'allez pas me croire ! Le message a disparu et je crois savoir pourquoi. En mettant en ligne le bulletin d'adhésion 2018 de l'association dans la page "Infothèque / Formulaires divers", j'ai vérifié (allez savoir pourquoi ?) la disponibilité de tous les autres documents en ligne de cette page. Et là, bizarrement les statuts ne s'affichaient plus. J'ai regardé dans la bibliothèque des fichiers présents sur le serveur pour voir si ce fichier "statuts" existait bien. Eh bien oui ! ce fichier y était mais ne s'affichait plus. J'ai donc recréé le lien en remettant ce fichier dans la bibliothèque, refait la mise en ligne  ... Et, au miracle : PLUS DE "FATAL ERROR".
Je ne sais pas pourquoi ce lien avait un problème mais il était très certainement à l'origine de ce msg.
Alain   
Haut de la page
Matt Izi allez vers le bas
Admin Group
Admin Group
Avatar

Depuis le: 02 Avril 2007
Statut: Inactif
Points: 5758
Options des messages Options des messages   Merci (0) Merci(0)   Citer Matt Izi Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 16 Janvier 2018 à 09:41
Bonjour,
Non notre développeur vient de corriger cette erreur. Cela venait d'un problème de php.

Bonne continuation
Haut de la page
alainjjb allez vers le bas
Senior Member
Senior Member


Depuis le: 20 Janvier 2010
Pays: France
Statut: Inactif
Points: 222
Options des messages Options des messages   Merci (0) Merci(0)   Citer alainjjb Citer  RépondreRéponse Lien Direct à ce Post Envoyé : 16 Janvier 2018 à 12:28
Bonjour Matt,
    est-ce que tu veux dire que le pb d'accès au fichier "Statuts" n'avait rien à voir avec le msg "Fatal error" ? Ce ne serait donc que pure coïncidence.
    Peux-tu nous en dire plus sur le problème de Php ? Ce problème datait de quand ?
Merci
Alain 
Haut de la page
 Répondre Répondre
  Partagez ce sujet   

Aller au Forum Permissions du forum allez vers le bas



Cette page a été affichée en 0,047 secondes.